Home / Блог / VRF Mikrotik и два USB 3G/LTE

VRF Mikrotik и два USB 3G/LTE

Встала задача обеспечит удаленный офис интернетом. Интернет возможен только через 3G/LTE модем.

Основная проблема возникла в том,  что модемы раздают одинаковую локальную сеть.

Первая и основная проблема, которая встает перед нами — это использование одинаковых IP-адресов или IP-адресов из одной подсети на разных интерфейсах маршрутизатора для обеспечения сетевой доступности целевых устройств. Как трактуют основы сетевого взаимодействия с одной таблицей маршрутизации такое сделать невозможно. Значит надо сделать несколько таблиц маршрутизации, и в этом нам поможет Virtual Routing and Forwarding (VRF). Не будем сильно погружаться в VRF — нам достаточно просто поместить разные интерфейсы в разные таблицы маршрутизации:

/ip route vrf
add interfaces=lte1 routing-mark=vrf_lte_1
add interfaces=lte2 routing-mark=vrf_lte_2

/ip firewall nat

add action=masquerade chain=srcnat comment=”defconf: masquerade” out-interface=lte1

add action=masquerade chain=srcnat comment=”defconf: masquerade” out-interface=lte2

/ip route

Настраиваем выход в интернет с локальной сети

add comment=”Internet for LAN” distance=1 dst-address=192.168.88.0/24 gateway=bridge routing-mark=vrf_lte_1
add comment=”Internet for LAN” distance=1 dst-address=192.168.88.0/24 gateway=bridge routing-mark=vrf_lte_2

Настраиваем выход в интернет с роутера
add comment=”LTE1 internet ” distance=1 gateway=192.168.8.1%lte1
add comment=”LTE2 internet” distance=1 gateway=192.168.8.1%lte2

Тестовый ip адресса серверов, требуется для настройки переключения каналов интернет
add comment=”Test LTE1″ distance=1 dst-address=4.2.2.4/32 gateway=192.168.8.1%lte1
add comment=”Test LTE2″ distance=1 dst-address=8.8.8.8/32 gateway=192.168.8.1%lte2

 

Проверяем интернет

Вот и все. Теперь осталось настроить переключение каналов.

Можно использовать: скрипты, NetWatch, либо Check Gateway

1 оценка, среднее: 10,00 из 101 оценка, среднее: 10,00 из 101 оценка, среднее: 10,00 из 101 оценка, среднее: 10,00 из 101 оценка, среднее: 10,00 из 101 оценка, среднее: 10,00 из 101 оценка, среднее: 10,00 из 101 оценка, среднее: 10,00 из 101 оценка, среднее: 10,00 из 101 оценка, среднее: 10,00 из 10 (1 оценок, среднее: 10,00 из 10)
Для того чтобы оценить запись, вы должны быть зарегистрированным пользователем сайта.
Загрузка...

About admin

admin

Добавить комментарий